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Welcome to AP Computer Science!  

The objective of this summer assignment is to ensure that each student has the capability at home to 
complete Java programming assignments, as well as to familiarize each student with the programming 

environment and expectations that will be utilized throughout the course.  As discussed in the course 
outline, every student in AP Computer Science must have access to a computer which will be available to 
complete homework programs and upon which the Java Development Kit is installed and appropriate 

utilities are configured. Windows-compatible systems are preferred so that you may use Textpad as your 
programming environment, but other systems may also be used as long as you take responsibility for 

installing the JDK and choosing and loading a suitable development environment. An older system 
running Windows Vista or Windows 7 (or later) is completely acceptable; homework programs will not 
require newer technology or significant amounts of memory or disk space. Chromebooks, tablets, 

smartphones, etc. are not acceptable.  Please see me immediately if this presents a significant hardship. 

I recommend that you begin the process early in the summer so that you have time to address any 

unexpected issues with hardware or configuration. You should aim to complete the installations (steps 1 
and 2) by July 31 and the programs (steps 3 and 4) by August 15 in order to allow adequate time for 
troubleshooting.  

The summer assignment will count for 60 points, approximately the same as a chapter test. To receive 
full credit for the summer assignment, you must perform the following tasks in the order specified and 

upload the specified files to the dropbox in the myDJO AP Computer Science page before the first day of 
class. Each task is explained in more detail in the attached directions. If you have questions or need 
help, please email me at kriley@bishopoconnell.org.  You may accept help from family members or 

friends for this assignment.  

1. Download and install the Java Software Development Kit (JDK) from Oracle's Java website (15 

points) 

2. Download and install Textpad (or a suitable alternative for non-Windows systems) (15 points) 

3. Type the SummerAssignment1 program into Textpad or your IDE; compile, debug, run, and use 

PrintScreen or SnippingTool to save an image of your output and the code to a Word file (15 
points) 

4. Type the SummerAssignment2 program into Textpad or your IDE; compile, debug, run, and use 
PrintScreen or SnippingTool to save an image of your output and the code to a Word file (15 
points) 

I will be checking my emails over the summer, albeit not as frequently as during the school year, so 
please allow a day or two for my response. I am happy to help you troubleshoot any difficulties that you 

run into during this process; email me at kriley@bishopoconnell.org with any questions. 

mailto:kriley@bishopoconnell.org
mailto:kriley@bishopoconnell.org


Step 1: Download and install the Java Software Development Kit (JDK) from Oracle's Java website 

 

Most internet-compatible systems come with the Java Runtime Environment (JRE) pre-installed, but not the 
Java Software Development Kit (JDK). The JDK is used to develop and compile Java programs, while the JRE, 
also known as the Java virtual machine, is used to run those programs. In order to write and compile Java 
programs in AP Computer Science, you will need both the JDK and the JRE and most likely will have to install 
the JDK on the computer that you plan to use for programming at home. 

Even if your system already has a version of the JDK, I recommend that you reinstall it in order to make sure 
that you have all the latest security updates. Please note that the JDK installation also updates the JRE 
installation by default. 

 

1: Download the Java Standard Edition Development Kit. 

The JDK is available free from the Oracle Technology Network at the following web page: 
http://www.oracle.com/technetwork/java/javase/downloads/index.html 

Open a browser, go to the URL above, and 
click on "JDK download." You must accept the 
agreement and then click on the download 
corresponding to the operating system that you 
are using. Most students will be using a 
modern 64-bit Windows PC, and so will choose 
the "Windows x64" option. Older Windows 
systems and other operating systems may 
require one of the other downloads.  You may 
verify your system type by going to "System 
Information" or its equivalent on the system.  

When the download is complete, open the folder containing the download and launch the executable that will 
install the JDK on your system. You may be asked if it may make changes to your device; answer "Yes." 

 

2. Accept the defaults for standard components and destination folder 
during the installation. When you get to the final screen, click "Close." 

 

3. You may check the list of installed programs on your operating system 
to verify that the JDK has been installed on your system.  If the JDK has 
been installed correctly, you will see "Java SE Development Kit" listed among the installed applications. 

 

To receive credit for this part of the assignment, you must take a screenshot of the list of installed programs on 
your system, showing that the JDK has been installed. You can get a list of installed programs by searching for 
"Apps and Features" or "Programs and Features" in Windows, or check your system documentation for details 
on how to do this on your system.  Paste the screenshot into a Word document with your name on it and upload 
the document to the "Part 1 Install JDK" folder. 

http://www.oracle.com/technetwork/java/javase/downloads/index.html


Step 2: Download and install Textpad 

TextPad is a shareware editor that includes syntax highlighting and menu commands to compile and run Java 
applications and applets. If you are using a Windows system for your assignments, please install Textpad. If you 
are not using a Windows system, you should install BlueJ or another similar editor which will allow you to edit 
and compile Java programs. 

 

Instructions for installing and configuring Textpad: 

1. Before installing Textpad, make sure that you have successfully installed the JDK (see previous 
instructions). If the JDK is not installed before installing Textpad, it will not automatically configure 
the Textpad tools. 
 

2. Go to the following address on your browser:  http://www.textpad.com . Click on the "Downloads" tab. 
Under "Textpad 8 Downloads," in the row labeled 
"English," click on the link for 64-bit (or 32-bit, if 
you have a much older, 32-bit system) to download 
the installation zip file. 
 

3. When the download is complete, double-click on the 
downloaded zip file and select "Extract All." Accept 
the default extract settings. 
 

4. Double-click on the "setup.exe" file that appears in 
the new extracted file directory in order to launch 
Textpad setup. You may be asked for a name and a 
company; type in whatever you wish. You may be asked if it may make changes to your device; answer 
"Yes." You may be asked if it may install/update Textpad; answer "Yes." Accept the defaults for all 
installation questions. 
 

5. After the installation is complete, open the Textpad program. Click on the "Tools" tab and then 
"External Tools."  A secondary 
menu should appear with the 
following options: Compile Java, 
Run Java Application, and Run 
Java Applet. If this secondary 
menu does not appear, Textpad 
did not find the JDK; un-install 
Textpad, re-install JDK, and 
then re-install Textpad. If you 
continue to have problems, 
please email me and I can help 
you troubleshoot the problem. 
 
 

To receive credit for this part of the assignment, you must take a screenshot of the Textpad window showing 
External tools, as shown above. Paste the screenshot into a Word document with your name on it and upload the 
document to the "Part 2 Install Textpad" folder. 

http://www.textpad.com/


Step 3: Type SummerAssignment1 program into Textpad or your IDE; compile, debug, and run 

The Summer Assignment 1 program will allow you to test your JDK and Textpad installations with a simple 
Java program. This will also give you an opportunity to compile, debug, and run an actual Java program. Please 
take special note of the following: 

- Before beginning to type, save the file as SummerAssignment1.java. The use of the .java extension 
enables Textpad to recognize Java syntax and color code / indent appropriately. 

- Before the executable code, you will insert a block comment identifying yourself as the author, the name 
of the assignment, and the date. A block comment is distinguished from executable code by the 
characters /* to begin the comment and */ to end the comment.  

- The first line of executable code in the file is the header, "public class SummerAssignment1."  Note that 
this is exactly the same as the name of the file; the name of the file and the public class must be 
identical, including upper and lower case. 

- Type in the code exactly as written. Semicolons, curly braces ( { or } ), capitalization, and spaces are all 
significant in java programming. 

Instructions for SummerAssignment1: 

1. Open Textpad 

2. Click on the File tab and choose "Save 
As... " 

3. In the File name box, type 
"SummerAssignment1" 

4. In "Save as type," choose Java (*.java) 

5. Type the code exactly as it appears 
below, except replace both instances of 
"your name here" with your own first 
and last name, and replace "insert 
date" with the actual date. Textpad 
will automatically use colored 
characters for different syntactical 
elements; if your code doesn't look like this, check for missing quotes or punctuation. 

 

 

 

 

 

 

 

 

 

 

 

 



6. When you have finished typing in the code 
exactly as written, save the file, and then 
click on Tools -> External Tools -> Compile 
Java . 
 
If your code is correct, you will see the 
message, "Tool completed successfully" in the 
Tool Output pane. If you see an error message 
instead, there is a mistake in your program. 
Find the mistake, correct it, and repeat step 6 
until you get the "Tool completed 
successfully" message. 

 
Note that the error messages generated by the 
compiler are sometimes misleading; small 
typos such as improper capitalization can 
confuse the compiler so that the entire 
program is misinterpreted.  
 
 
 
 
 
 
 
 

7. Once your code compiles correctly, click on Tools -> External Tools -> Run Java Application. If the 
program runs correctly, a command window should appear with the words: "Hello AP Computer Science" 
followed by "My name is <your name>" and "Press any key to continue…" If so, congratulations! If not, or 
if you get an error when you run the program, find your mistake, recompile, and rerun. 

 

 

 

 

 

 

 

 

 

 

 

To receive credit for this part of the assignment, you must take a screenshot of the Textpad window showing 
your code as well as the command window with the correct program output, as shown directly above. Paste the 
screenshot into a Word document with your name on it and upload the document to the "Part 3 Install 
SummerAssignment1" folder. 



Step 4: Type SummerAssignment2 program into Textpad or your IDE; compile, debug, and run 

The Summer Assignment 1 program will give you additional practice compiling, debugging, and running 
another Java program. This program will also demonstrate how to programmatically interrogate the operating 
system and identify your system. 

Type in the code exactly as written.  

 

Instructions for SummerAssignment2: 

1. Open Textpad 

2. Click on the File tab and choose "Save 
As... " 

3. In the File name box, type 
"SummerAssignment2" 

4. In "Save as type," choose Java (*.java) 

5. Type the code exactly as it appears 
below, except replace both instances of 
"your name here" with your own first 
and last name, and replace "insert 
date" with the actual date. Textpad 
will automatically use colored 
characters for different syntactical 
elements; if your code doesn't look like this, check for missing quotes or punctuation. 



6. When you have finished typing in the code exactly as written, save the file, and then click on Tools -> 
External Tools -> Compile Java . 
 
If your code is correct, you will see the message, "Tool completed successfully" in the Tool Output pane. 
If you see an error message instead, there is a mistake in your program. Find the mistake, correct it, and 
repeat step 6 until you get the "Tool completed successfully" message. 
 
Remember that the error messages generated by the compiler are sometimes misleading; small typos such 
as improper capitalization can confuse the compiler so that the entire program is misinterpreted.  
 
 

7. Once your code compiles correctly, click on Tools -> External Tools -> Run Java Application. If the 
program runs correctly, a command window should appear displaying output similar to the following:   

 
 

8. If your output looks similar to the above, congratulations! If not, or if you get an error when you run the 
program, find your mistake, recompile, and rerun until you are satisfied with the results. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To receive credit for this part of the assignment, you must take a screenshot of the Textpad window showing 
your code as well as the command window with the correct program output, as shown directly above. Paste the 
screenshot into a Word document with your name on it and upload the document to the "Part 4 Install 
SummerAssignment1" folder. 




